CVE-2007-2756
Open Enterprise Server,SUSE LINUX 10.0,SUSE LINUX 10.1,SUSE LINUX Retail Solution 8,SuSE Linux Enterprise Server 8 for AMD64,SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries,SuSE Linux Enterprise Server 8 for IBM zSeries,SuSE Linux Enterprise Server 8 for IPF,SuSE Linux Openexchange Server 4,SuSE Linux School Server for i386,SuSE Linux Standard Server 8,UnitedLinux 1.0
CVE-2007-2756, security advisory, novell, suse linux, suse, security, cve

CVE-2007-2756

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2007-2756 at MITRE

Description

The gdPngReadData function in libgd 2.0.34 allows user-assisted attackers to cause a denial of service (CPU consumption) via a crafted PNG image with truncated data, which causes an infinite loop in the png_read_info function in libpng.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 276525 [RESOLVED / FIXED], 282730 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
SUSE LINUX 10.1
  • apache2-mod_php5 >= 5.1.2-29.40
  • php5 >= 5.1.2-29.40
  • php5-bcmath >= 5.1.2-29.40
  • php5-bz2 >= 5.1.2-29.40
  • php5-calendar >= 5.1.2-29.40
  • php5-ctype >= 5.1.2-29.40
  • php5-curl >= 5.1.2-29.40
  • php5-dba >= 5.1.2-29.40
  • php5-dbase >= 5.1.2-29.40
  • php5-devel >= 5.1.2-29.40
  • php5-dom >= 5.1.2-29.40
  • php5-exif >= 5.1.2-29.40
  • php5-fastcgi >= 5.1.2-29.40
  • php5-filepro >= 5.1.2-29.40
  • php5-ftp >= 5.1.2-29.40
  • php5-gd >= 5.1.2-29.40
  • php5-gettext >= 5.1.2-29.40
  • php5-gmp >= 5.1.2-29.40
  • php5-iconv >= 5.1.2-29.40
  • php5-imap >= 5.1.2-29.40
  • php5-ldap >= 5.1.2-29.40
  • php5-mbstring >= 5.1.2-29.40
  • php5-mcrypt >= 5.1.2-29.40
  • php5-mhash >= 5.1.2-29.40
  • php5-mysql >= 5.1.2-29.40
  • php5-mysqli >= 5.1.2-29.40
  • php5-ncurses >= 5.1.2-29.40
  • php5-odbc >= 5.1.2-29.40
  • php5-openssl >= 5.1.2-29.40
  • php5-pcntl >= 5.1.2-29.40
  • php5-pdo >= 5.1.2-29.40
  • php5-pear >= 5.1.2-29.40
  • php5-pgsql >= 5.1.2-29.40
  • php5-posix >= 5.1.2-29.40
  • php5-pspell >= 5.1.2-29.40
  • php5-shmop >= 5.1.2-29.40
  • php5-snmp >= 5.1.2-29.40
  • php5-soap >= 5.1.2-29.40
  • php5-sockets >= 5.1.2-29.40
  • php5-sqlite >= 5.1.2-29.40
  • php5-sysvmsg >= 5.1.2-29.40
  • php5-sysvsem >= 5.1.2-29.40
  • php5-sysvshm >= 5.1.2-29.40
  • php5-tidy >= 5.1.2-29.40
  • php5-tokenizer >= 5.1.2-29.40
  • php5-wddx >= 5.1.2-29.40
  • php5-xmlreader >= 5.1.2-29.40
  • php5-xmlrpc >= 5.1.2-29.40
  • php5-xsl >= 5.1.2-29.40
  • php5-zlib >= 5.1.2-29.40
SUSE LINUX 10.0
  • apache2-mod_php5 >= 5.0.4-9.29
  • php5 >= 5.0.4-9.29
  • php5-bcmath >= 5.0.4-9.29
  • php5-bz2 >= 5.0.4-9.29
  • php5-calendar >= 5.0.4-9.29
  • php5-ctype >= 5.0.4-9.29
  • php5-curl >= 5.0.4-9.29
  • php5-dbase >= 5.0.4-9.29
  • php5-devel >= 5.0.4-9.29
  • php5-dom >= 5.0.4-9.29
  • php5-exif >= 5.0.4-9.29
  • php5-fastcgi >= 5.0.4-9.29
  • php5-filepro >= 5.0.4-9.29
  • php5-ftp >= 5.0.4-9.29
  • php5-gd >= 5.0.4-9.29
  • php5-gettext >= 5.0.4-9.29
  • php5-gmp >= 5.0.4-9.29
  • php5-iconv >= 5.0.4-9.29
  • php5-imap >= 5.0.4-9.29
  • php5-ldap >= 5.0.4-9.29
  • php5-mbstring >= 5.0.4-9.29
  • php5-mcrypt >= 5.0.4-9.29
  • php5-mhash >= 5.0.4-9.29
  • php5-mysql >= 5.0.4-9.29
  • php5-mysqli >= 5.0.4-9.29
  • php5-ncurses >= 5.0.4-9.29
  • php5-odbc >= 5.0.4-9.29
  • php5-openssl >= 5.0.4-9.29
  • php5-pcntl >= 5.0.4-9.29
  • php5-pear >= 5.0.4-9.29
  • php5-pgsql >= 5.0.4-9.29
  • php5-posix >= 5.0.4-9.29
  • php5-pspell >= 5.0.4-9.29
  • php5-shmop >= 5.0.4-9.29
  • php5-snmp >= 5.0.4-9.29
  • php5-soap >= 5.0.4-9.29
  • php5-sockets >= 5.0.4-9.29
  • php5-sqlite >= 5.0.4-9.29
  • php5-sysvmsg >= 5.0.4-9.29
  • php5-sysvsem >= 5.0.4-9.29
  • php5-sysvshm >= 5.0.4-9.29
  • php5-tokenizer >= 5.0.4-9.29
  • php5-wddx >= 5.0.4-9.29
  • php5-xmlrpc >= 5.0.4-9.29
  • php5-xsl >= 5.0.4-9.29
  • php5-zlib >= 5.0.4-9.29
SUSE LINUX 10.0
  • gd >= 2.0.32-7.5
  • gd-devel >= 2.0.32-7.5
SUSE LINUX 10.1
  • gd >= 2.0.32-23.7
  • gd-devel >= 2.0.32-23.7
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • gd >= 1.8.4-530
  • gd-devel >= 1.8.4-529
slrs8.x86
core9.x86
ul1.s390
core9.s390
YOU Patch Nr: 11553
Open Enterprise Server
  • gd >= 2.0.22-65.12
  • gd-devel >= 2.0.22-65.12
slrs8.x86
core9.x86
ul1.s390
core9.s390
YOU Patch Nr: 11553
Open Enterprise Server
  • apache-mod_php4 >= 4.3.4-43.79
  • apache2-mod_php4 >= 4.3.4-43.79
  • mod_php4 >= 4.3.4-43.79
  • mod_php4-apache2 >= 4.3.4-43.79
  • mod_php4-core >= 4.3.4-43.79
  • mod_php4-servlet >= 4.3.4-43.79
  • php4 >= 4.3.4-43.79
  • php4-bcmath >= 4.3.4-43.79
  • php4-bz2 >= 4.3.4-43.79
  • php4-calendar >= 4.3.4-43.79
  • php4-ctype >= 4.3.4-43.79
  • php4-curl >= 4.3.4-43.79
  • php4-dba >= 4.3.4-43.79
  • php4-dbase >= 4.3.4-43.79
  • php4-devel >= 4.3.4-43.79
  • php4-domxml >= 4.3.4-43.79
  • php4-exif >= 4.3.4-43.79
  • php4-fastcgi >= 4.3.4-43.79
  • php4-filepro >= 4.3.4-43.79
  • php4-ftp >= 4.3.4-43.79
  • php4-gd >= 4.3.4-43.79
  • php4-gettext >= 4.3.4-43.79
  • php4-gmp >= 4.3.4-43.79
  • php4-iconv >= 4.3.4-43.79
  • php4-imap >= 4.3.4-43.79
  • php4-ldap >= 4.3.4-43.79
  • php4-mbstring >= 4.3.4-43.79
  • php4-mcal >= 4.3.4-43.79
  • php4-mcrypt >= 4.3.4-43.79
  • php4-mhash >= 4.3.4-43.79
  • php4-mime_magic >= 4.3.4-43.79
  • php4-mysql >= 4.3.4-43.79
  • php4-pear >= 4.3.4-43.79
  • php4-pgsql >= 4.3.4-43.79
  • php4-qtdom >= 4.3.4-43.79
  • php4-readline >= 4.3.4-43.79
  • php4-recode >= 4.3.4-43.79
  • php4-servlet >= 4.3.4-43.79
  • php4-session >= 4.3.4-43.79
  • php4-shmop >= 4.3.4-43.79
  • php4-snmp >= 4.3.4-43.79
  • php4-sockets >= 4.3.4-43.79
  • php4-swf >= 4.3.4-43.79
  • php4-sysvsem >= 4.3.4-43.79
  • php4-sysvshm >= 4.3.4-43.79
  • php4-unixODBC >= 4.3.4-43.79
  • php4-wddx >= 4.3.4-43.79
  • php4-xslt >= 4.3.4-43.79
  • php4-yp >= 4.3.4-43.79
  • php4-zlib >= 4.3.4-43.79
core9.s390
core9.x86
YOU Patch Nr: 11557
SUSE LINUX 10.0
  • apache2-mod_php4 >= 4.4.0-6.29
  • mod_php4-apache2 >= 4.4.0-6.29
  • mod_php4-core >= 4.4.0-6.29
  • mod_php4-servlet >= 4.4.0-6.29
  • php4 >= 4.4.0-6.29
  • php4-32bit >= 4.4.0-6.29
  • php4-64bit >= 4.4.0-6.29
  • php4-bcmath >= 4.4.0-6.29
  • php4-bz2 >= 4.4.0-6.29
  • php4-calendar >= 4.4.0-6.29
  • php4-ctype >= 4.4.0-6.29
  • php4-curl >= 4.4.0-6.29
  • php4-dbase >= 4.4.0-6.29
  • php4-dbx >= 4.4.0-6.29
  • php4-devel >= 4.4.0-6.29
  • php4-domxml >= 4.4.0-6.29
  • php4-exif >= 4.4.0-6.29
  • php4-fastcgi >= 4.4.0-6.29
  • php4-filepro >= 4.4.0-6.29
  • php4-ftp >= 4.4.0-6.29
  • php4-gd >= 4.4.0-6.29
  • php4-gettext >= 4.4.0-6.29
  • php4-gmp >= 4.4.0-6.29
  • php4-iconv >= 4.4.0-6.29
  • php4-imap >= 4.4.0-6.29
  • php4-ldap >= 4.4.0-6.29
  • php4-mbstring >= 4.4.0-6.29
  • php4-mcal >= 4.4.0-6.29
  • php4-mcrypt >= 4.4.0-6.29
  • php4-mhash >= 4.4.0-6.29
  • php4-mime_magic >= 4.4.0-6.29
  • php4-mysql >= 4.4.0-6.29
  • php4-pear >= 4.4.0-6.29
  • php4-pgsql >= 4.4.0-6.29
  • php4-qtdom >= 4.4.0-6.29
  • php4-recode >= 4.4.0-6.29
  • php4-servlet >= 4.4.0-6.29
  • php4-session >= 4.4.0-6.29
  • php4-shmop >= 4.4.0-6.29
  • php4-snmp >= 4.4.0-6.29
  • php4-sockets >= 4.4.0-6.29
  • php4-swf >= 4.4.0-6.29
  • php4-sysvsem >= 4.4.0-6.29
  • php4-sysvshm >= 4.4.0-6.29
  • php4-unixODBC >= 4.4.0-6.29
  • php4-wddx >= 4.4.0-6.29
  • php4-xslt >= 4.4.0-6.29
  • php4-yp >= 4.4.0-6.29
  • php4-zlib >= 4.4.0-6.29