CVE-2011-1485
openSUSE 11.3,openSUSE 11.4
CVE-2011-1485, security advisory, novell, suse linux, suse, security, cve

CVE-2011-1485

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2011-1485 at MITRE

Description

Race condition in the pkexec utility and polkitd daemon in PolicyKit (aka polkit) 0.96 allows local users to gain privileges by executing a setuid program from pkexec, related to the use of the effective user ID instead of the real user ID.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.9
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete

Note from the SUSE Security Team

This newer version of polkit is not shipped on SUSE Linux Enterprise 9, 10 or 11, so they are not affected. We only started shipping it with openSUSE 11.2.

SUSE Bugzilla entry: 688788 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Software Development Kit 12 SP1
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
SUSE Linux Enterprise Workstation Extension 12
SUSE Linux Enterprise Workstation Extension 12 SP1
SUSE Linux Enterprise Workstation Extension 12 SP2
SUSE Linux Enterprise Workstation Extension 12 SP3
SUSE Linux Enterprise Workstation Extension 12 SP4
SUSE Linux Enterprise Workstation Extension 12 SP5
openSUSE 11.4
  • libpolkit0 >= 0.99-5.6.1
  • libpolkit0-32bit >= 0.99-5.6.1
  • polkit >= 0.99-5.6.1
  • polkit-devel >= 0.99-5.6.1
  • polkit-doc >= 0.99-5.6.1
openSUSE 11.3
  • libpolkit0-debuginfo >= 0.96-5.3.1
  • libpolkit0-debuginfo-32bit >= 0.96-5.3.1
  • polkit-debuginfo >= 0.96-5.3.1
  • polkit-debugsource >= 0.96-5.3.1
  • polkit-devel-debuginfo >= 0.96-5.3.1
openSUSE 11.3
  • libpolkit0 >= 0.96-5.3.1
  • libpolkit0-32bit >= 0.96-5.3.1
  • polkit >= 0.96-5.3.1
  • polkit-devel >= 0.96-5.3.1
  • polkit-doc >= 0.96-5.3.1
openSUSE 11.4
  • libpolkit0 >= 0.99-5.6.1
  • libpolkit0-32bit >= 0.99-5.6.1
  • libpolkit0-debuginfo >= 0.99-5.6.1
  • libpolkit0-debuginfo-32bit >= 0.99-5.6.1
  • polkit >= 0.99-5.6.1
  • polkit-debuginfo >= 0.99-5.6.1
  • polkit-debugsource >= 0.99-5.6.1
  • polkit-devel >= 0.99-5.6.1
  • polkit-devel-debuginfo >= 0.99-5.6.1
  • polkit-doc >= 0.99-5.6.1
Patchnames:
libpolkit0
openSUSE Leap 15.0
  • libpolkit0 >= 0.114-lp150.1.6
  • polkit >= 0.114-lp150.1.6
  • typelib-1_0-Polkit-1_0 >= 0.114-lp150.1.6
Patchnames:
openSUSE Leap 15.0 GA libpolkit0
openSUSE Leap 42.1
  • libpolkit0 >= 0.112-4.2
  • polkit >= 0.112-4.2
  • polkit-devel >= 0.112-4.2
  • typelib-1_0-Polkit-1_0 >= 0.112-4.2
Patchnames:
openSUSE Leap 42.1 GA libpolkit0
openSUSE Leap 42.2
  • libpolkit0 >= 0.113-10.1
  • polkit >= 0.113-10.1
  • polkit-devel >= 0.113-10.1
  • typelib-1_0-Polkit-1_0 >= 0.113-10.1
Patchnames:
openSUSE Leap 42.2 GA libpolkit0
openSUSE Leap 42.3
  • libpolkit0 >= 0.113-13.1
  • polkit >= 0.113-13.1
  • polkit-devel >= 0.113-13.1
  • typelib-1_0-Polkit-1_0 >= 0.113-13.1
Patchnames:
openSUSE Leap 42.3 GA libpolkit0
openSUSE Tumbleweed
  • libpolkit0 >= 0.113-3.4
  • libpolkit0-32bit >= 0.113-3.4
  • polkit >= 0.113-3.4
  • polkit-devel >= 0.113-3.4
  • polkit-doc >= 0.113-3.4
  • typelib-1_0-Polkit-1_0 >= 0.113-3.4
Patchnames:
openSUSE Tumbleweed GA libpolkit0