CVE-2012-1013
CVE-2012-1013, security advisory, novell, suse linux, suse, security, cve

CVE-2012-1013

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2012-1013 at MITRE

Description

The check_1_6_dummy function in lib/kadm5/srv/svr_principal.c in kadmind in MIT Kerberos 5 (aka krb5) 1.8.x, 1.9.x, and 1.10.x before 1.10.2 allows remote authenticated administrators to cause a denial of service (NULL pointer dereference and daemon crash) via a KRB5_KDB_DISALLOW_ALL_TIX create request that lacks a password.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 765485 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Server Applications 15
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Software Development Kit 12 SP1
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
openSUSE 11.4
  • krb5 >= 1.8.3-16.49.1
  • krb5-32bit >= 1.8.3-16.49.1
  • krb5-client >= 1.8.3-16.49.1
  • krb5-client-debuginfo >= 1.8.3-16.49.1
  • krb5-debuginfo >= 1.8.3-16.49.1
  • krb5-debuginfo-32bit >= 1.8.3-16.49.1
  • krb5-debuginfo-x86 >= 1.8.3-16.49.1
  • krb5-debuginfo-x86-debuginfo >= 1.8.3-16.49.1
  • krb5-debugsource >= 1.8.3-16.49.1
  • krb5-devel >= 1.8.3-16.49.1
  • krb5-devel-32bit >= 1.8.3-16.49.1
  • krb5-plugin-kdb-ldap >= 1.8.3-16.49.1
  • krb5-plugin-kdb-ldap-debuginfo >= 1.8.3-16.49.1
  • krb5-plugin-preauth-pkinit >= 1.8.3-16.49.1
  • krb5-plugin-preauth-pkinit-debuginfo >= 1.8.3-16.49.1
  • krb5-server >= 1.8.3-16.49.1
  • krb5-server-debuginfo >= 1.8.3-16.49.1
  • krb5-x86 >= 1.8.3-16.49.1
Patchnames:
openSUSE-2012-360
openSUSE Leap 15.0
  • krb5 >= 1.15.2-lp150.4.4
  • krb5-32bit >= 1.15.2-lp150.4.4
  • krb5-server >= 1.15.2-lp150.4.4
Patchnames:
openSUSE Leap 15.0 GA krb5
openSUSE Leap 42.1
  • krb5 >= 1.12.1-19.9
  • krb5-32bit >= 1.12.1-19.9
  • krb5-client >= 1.12.1-19.9
  • krb5-devel >= 1.12.1-19.9
Patchnames:
openSUSE Leap 42.1 GA krb5
openSUSE Leap 42.2
  • krb5 >= 1.12.5-5.13
  • krb5-32bit >= 1.12.5-5.13
  • krb5-client >= 1.12.5-5.13
  • krb5-devel >= 1.12.5-5.13
Patchnames:
openSUSE Leap 42.2 GA krb5
openSUSE Leap 42.3
  • krb5 >= 1.12.5-7.17
  • krb5-32bit >= 1.12.5-7.17
  • krb5-client >= 1.12.5-7.17
  • krb5-devel >= 1.12.5-7.17
Patchnames:
openSUSE Leap 42.3 GA krb5
openSUSE Tumbleweed
  • krb5 >= 1.15-1.1
  • krb5-32bit >= 1.15-1.1
  • krb5-client >= 1.15-1.1
  • krb5-devel >= 1.15-1.1
  • krb5-devel-32bit >= 1.15-1.1
  • krb5-doc >= 1.15-1.1
  • krb5-mini >= 1.15-1.1
  • krb5-mini-devel >= 1.15-1.1
  • krb5-plugin-kdb-ldap >= 1.15-1.1
  • krb5-plugin-preauth-otp >= 1.15-1.1
  • krb5-plugin-preauth-pkinit >= 1.15-1.1
  • krb5-server >= 1.15-1.1
Patchnames:
openSUSE Tumbleweed GA krb5