CVE-2012-2738
CVE-2012-2738, security advisory, novell, suse linux, suse, security, cve

CVE-2012-2738

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2012-2738 at MITRE

Description

The VteTerminal in gnome-terminal (vte) before 0.32.2 allows remote authenticated users to cause a denial of service (long loop and CPU consumption) via an escape sequence with a large repeat count value.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 772761 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Software Development Kit 12 SP1
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
openSUSE 11.4
  • glade3-catalog-vte >= 0.26.2-5.1
  • libvte9 >= 0.26.2-5.1
  • libvte9-debuginfo >= 0.26.2-5.1
  • python-vte >= 0.26.2-5.1
  • python-vte-debuginfo >= 0.26.2-5.1
  • vte >= 0.26.2-5.1
  • vte-debugsource >= 0.26.2-5.1
  • vte-devel >= 0.26.2-5.1
  • vte-lang >= 0.26.2-5.1
  • vte-tools >= 0.26.2-5.1
  • vte-tools-debuginfo >= 0.26.2-5.1
Patchnames:
openSUSE-2012-471
openSUSE Leap 42.1
  • libvte9 >= 0.28.2-19.1
  • vte2-lang >= 0.28.2-19.1
Patchnames:
openSUSE Leap 42.1 GA libvte9
openSUSE Leap 42.2
  • libvte9 >= 0.28.2-21.3
  • vte2-lang >= 0.28.2-21.3
Patchnames:
openSUSE Leap 42.2 GA libvte9
openSUSE Leap 42.3
  • libvte9 >= 0.28.2-23.1
  • vte2-lang >= 0.28.2-23.1
Patchnames:
openSUSE Leap 42.3 GA libvte9
openSUSE Tumbleweed
  • glade3-catalog-vte >= 0.28.2-22.1
  • libvte9 >= 0.28.2-22.1
  • python-vte >= 0.28.2-22.1
  • vte2-devel >= 0.28.2-22.1
  • vte2-lang >= 0.28.2-22.1
  • vte2-tools >= 0.28.2-22.1
Patchnames:
openSUSE Tumbleweed GA glade3-catalog-vte