CVE-2015-0242
SUSE Linux Enterprise Desktop 11 SP3,SUSE Linux Enterprise Server 11 SP3,SUSE Linux Enterprise Server 11 SP3 for VMware,SUSE Linux Enterprise Software Development Kit 11 SP3,SUSE Manager Server
CVE-2015-0242, security advisory, novell, suse linux, suse, security, cve

CVE-2015-0242

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2015-0242 at MITRE

Description

Stack-based buffer overflow in the *printf function implementations in PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1, when running on a Windows system, allows remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via a floating point number with a large precision, as demonstrated by using the to_char function.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
No SUSE Bugzilla entries cross referenced.

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Manager Server
  • postgresql91-pltcl >= 9.1.15-0.3.1
Builds
SAT Patch Nr: 10389
SUSE Linux Enterprise Software Development Kit 11 SP3
  • postgresql91-devel >= 9.1.15-0.3.1
Builds
SAT Patch Nr: 10389
SUSE Linux Enterprise Desktop 11 SP3
  • libecpg6 >= 9.1.15-0.3.1
  • libpq5 >= 9.1.15-0.3.1
  • postgresql91 >= 9.1.15-0.3.1
  • postgresql91-docs >= 9.1.15-0.3.1
Builds
SAT Patch Nr: 10389
SUSE Linux Enterprise Desktop 11 SP3
  • libecpg6 >= 9.1.15-0.3.1
  • libpq5 >= 9.1.15-0.3.1
  • libpq5-32bit >= 9.1.15-0.3.1
  • postgresql91 >= 9.1.15-0.3.1
  • postgresql91-docs >= 9.1.15-0.3.1
Builds
SAT Patch Nr: 10389
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libecpg6 >= 9.1.15-0.3.1
  • libpq5 >= 9.1.15-0.3.1
  • libpq5-32bit >= 9.1.15-0.3.1
  • postgresql91 >= 9.1.15-0.3.1
  • postgresql91-contrib >= 9.1.15-0.3.1
  • postgresql91-docs >= 9.1.15-0.3.1
  • postgresql91-server >= 9.1.15-0.3.1
Builds
SAT Patch Nr: 10389
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libecpg6 >= 9.1.15-0.3.1
  • libpq5 >= 9.1.15-0.3.1
  • postgresql91 >= 9.1.15-0.3.1
  • postgresql91-contrib >= 9.1.15-0.3.1
  • postgresql91-docs >= 9.1.15-0.3.1
  • postgresql91-server >= 9.1.15-0.3.1
Builds
SAT Patch Nr: 10389
openSUSE Leap 42.2
  • postgresql93-docs >= 9.3.11-4.1
Patchnames:
openSUSE Leap 42.2 GA postgresql93-docs
openSUSE Leap 42.3
  • postgresql93-docs >= 9.3.17-6.1
Patchnames:
openSUSE Leap 42.3 GA postgresql93-docs
openSUSE Tumbleweed
  • postgresql93 >= 9.3.15-1.1
  • postgresql93-contrib >= 9.3.15-1.1
  • postgresql93-devel >= 9.3.15-1.1
  • postgresql93-docs >= 9.3.15-1.1
  • postgresql93-plperl >= 9.3.15-1.1
  • postgresql93-plpython >= 9.3.15-1.1
  • postgresql93-pltcl >= 9.3.15-1.1
  • postgresql93-server >= 9.3.15-1.1
  • postgresql93-test >= 9.3.15-1.1
Patchnames:
openSUSE Tumbleweed GA postgresql93