CVE-2015-4041
CVE-2015-4041, security advisory, novell, suse linux, suse, security, cve

CVE-2015-4041

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2015-4041 at MITRE

Description

The keycompare_mb function in sort.c in sort in GNU Coreutils through 8.23 on 64-bit platforms performs a size calculation without considering the number of bytes occupied by multibyte characters, which allows attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via long UTF-8 strings.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

SUSE Bugzilla entry: 928749 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
SUSE Linux Enterprise Desktop 12
  • coreutils >= 8.22-9.1
  • coreutils-lang >= 8.22-9.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-599
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • coreutils >= 8.22-9.1
  • coreutils-lang >= 8.22-9.1
Patchnames:
SUSE-SLE-SERVER-12-2015-599
openSUSE Leap 15.0
  • coreutils >= 8.29-lp150.2.2
  • coreutils-lang >= 8.29-lp150.2.2
Patchnames:
openSUSE Leap 15.0 GA coreutils
openSUSE Leap 42.1
  • coreutils >= 8.22-4.1
  • coreutils-lang >= 8.22-4.1
Patchnames:
openSUSE Leap 42.1 GA coreutils
openSUSE Leap 42.2
  • coreutils >= 8.25-1.4
  • coreutils-lang >= 8.25-1.4
Patchnames:
openSUSE Leap 42.2 GA coreutils
openSUSE Leap 42.3
  • coreutils >= 8.25-3.3
  • coreutils-lang >= 8.25-3.3
Patchnames:
openSUSE Leap 42.3 GA coreutils
openSUSE Tumbleweed
  • coreutils >= 8.26-1.1
  • coreutils-lang >= 8.26-1.1
  • coreutils-testsuite >= 8.26-1.1
Patchnames:
openSUSE Tumbleweed GA coreutils


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 coreutils Released
SUSE Linux Enterprise Desktop 11 SP3 coreutils Affected
SUSE Linux Enterprise Desktop 12 GA coreutils Released
SUSE Linux Enterprise Desktop 12 SP1 coreutils Released
SUSE Linux Enterprise Server 10 SP3 coreutils Released
SUSE Linux Enterprise Server 11 SP3 coreutils Affected
SUSE Linux Enterprise Server 12 GA coreutils Released
SUSE Linux Enterprise Server 12 SP1 coreutils Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 coreutils Already fixed
SUSE Linux Enterprise Server for VMWare 11 SP3 coreutils Affected