CVE-2015-5315, security advisory, novell, suse linux, suse, security, cve


Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2015-5315 at MITRE


The eap_pwd_process function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when EAP-pwd is enabled in a network configuration profile, which allows remote attackers to cause a denial of service (process termination) via a large final fragment in an EAP-pwd message.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 953115 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • wpa_supplicant >= 2.6-15.10.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • wpa_supplicant >= 2.6-4.11.1
SUSE Linux Enterprise Module for Basesystem 15
  • wpa_supplicant >= 2.6-2.50
openSUSE Leap 15.0
  • wpa_supplicant >= 2.6-lp150.2.13
openSUSE Leap 15.0 GA wpa_supplicant
openSUSE Tumbleweed
  • wpa_supplicant >= 2.6-1.1
  • wpa_supplicant-gui >= 2.6-1.1
openSUSE Tumbleweed GA wpa_supplicant