CVE-2016-8628
CVE-2016-8628, security advisory, novell, suse linux, suse, security, cve

CVE-2016-8628

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2016-8628 at MITRE

Description

Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to create special variables on the controller could execute arbitrary commands on Ansible clients as the user Ansible runs as.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 9 6
Vector AV:N/AC:L/Au:S/C:C/I:C/A:C AV:N/AC:M/Au:S/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication Single Single
Confidentiality Impact Complete Partial
Integrity Impact Complete Partial
Availability Impact Complete Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.1
Vector AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required High
User Interaction None
Scope Changed
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1008037 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub for SUSE Linux Enterprise 12
  • ansible >= 2.4.1.0-6.1
Patchnames:
openSUSE-2017-1259
openSUSE Leap 42.2
  • ansible >= 2.4.1.0-2.4.1
Patchnames:
openSUSE-2017-1259
openSUSE Leap 42.3
  • ansible >= 2.4.1.0-6.1
Patchnames:
openSUSE-2017-1259


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State