CVE-2017-10689
CVE-2017-10689, security advisory, novell, suse linux, suse, security, cve

CVE-2017-10689

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2017-10689 at MITRE

Description

In previous versions of Puppet Agent it was possible to install a module with world writable permissions. Puppet Agent 5.3.4 and 1.10.10 included a fix to this vulnerability.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:N/I:P/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 5
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
Access Vector Local Network
Access Complexity Low High
Privileges Required Low None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact None Low
Integrity Impact High Low
Availability Impact None Low
SUSE Bugzilla entry: 1080288 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • puppet >= 3.8.5-15.9.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-379
SUSE Linux Enterprise Desktop 12 SP3
  • puppet >= 3.8.5-15.9.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-379
SUSE Linux Enterprise Desktop 12 SP4
  • puppet >= 3.8.5-15.9.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA puppet
SUSE Linux Enterprise Module for Advanced Systems Management 12
  • puppet >= 3.8.5-15.9.1
  • puppet-server >= 3.8.5-15.9.1
  • ruby2.1-rubygem-puppet >= 4.8.1-32.3.1
  • rubygem-puppet >= 4.8.1-32.3.1
Patchnames:
SUSE-SLE-Module-Adv-Systems-Management-12-2018-379
SUSE-SLE-Module-Adv-Systems-Management-12-2018-409
openSUSE Leap 42.3
  • ruby2.1-rubygem-puppet >= 3.8.7-23.1
  • ruby2.1-rubygem-puppet-doc >= 3.8.7-23.1
  • ruby2.1-rubygem-puppet-testsuite >= 3.8.7-23.1
  • ruby2.2-rubygem-puppet >= 3.8.7-23.1
  • ruby2.2-rubygem-puppet-doc >= 3.8.7-23.1
  • ruby2.2-rubygem-puppet-testsuite >= 3.8.7-23.1
  • ruby2.3-rubygem-puppet >= 3.8.7-23.1
  • ruby2.3-rubygem-puppet-doc >= 3.8.7-23.1
  • ruby2.3-rubygem-puppet-testsuite >= 3.8.7-23.1
  • ruby2.4-rubygem-puppet >= 3.8.7-23.1
  • ruby2.4-rubygem-puppet-doc >= 3.8.7-23.1
  • ruby2.4-rubygem-puppet-testsuite >= 3.8.7-23.1
  • rubygem-puppet >= 3.8.7-23.1
  • rubygem-puppet-emacs >= 3.8.7-23.1
  • rubygem-puppet-master >= 3.8.7-23.1
  • rubygem-puppet-master-unicorn >= 3.8.7-23.1
  • rubygem-puppet-vim >= 3.8.7-23.1
Patchnames:
openSUSE-2018-174


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 puppet Released
SUSE Linux Enterprise Desktop 12 SP3 puppet Released
SUSE Linux Enterprise Module for Advanced Systems Management 12 puppet Released
SUSE Linux Enterprise Module for Advanced Systems Management 12 rubygem-puppet Released
SUSE Linux Enterprise Server 11 SP3 LTSS puppet Not affected
SUSE Linux Enterprise Server 11 SP4 puppet Not affected