CVE-2017-17564
CVE-2017-17564, security advisory, novell, suse linux, suse, security, cve

CVE-2017-17564

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2017-17564 at MITRE

Description

An issue was discovered in Xen through 4.9.x allowing guest OS users to cause a denial of service (host OS crash) or gain host OS privileges by leveraging incorrect error handling for reference counting in shadow mode.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.9 4.9
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C AV:A/AC:M/Au:S/C:P/I:P/A:P
Access Vector Local Adjacent Network
Access Complexity Medium Medium
Authentication None Single
Confidentiality Impact Complete Partial
Integrity Impact Complete Partial
Availability Impact Complete Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 6.5
Vector AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H AV:A/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Access Vector Local Adjacent Network
Access Complexity High Low
Privileges Required Low Low
User Interaction None None
Scope Changed Changed
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
SUSE Bugzilla entry: 1070160 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform ALL
  • xen >= 4.9.1_08-3.26.1
  • xen-libs >= 4.9.1_08-3.26.1
  • xen-tools-domU >= 4.9.1_08-3.26.1
Patchnames:
SUSE-CAASP-ALL-2018-302
SUSE Linux Enterprise Desktop 12 SP2
  • xen >= 4.7.4_06-43.24.1
  • xen-libs >= 4.7.4_06-43.24.1
  • xen-libs-32bit >= 4.7.4_06-43.24.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-325
SUSE Linux Enterprise Desktop 12 SP3
  • xen >= 4.9.1_08-3.26.1
  • xen-libs >= 4.9.1_08-3.26.1
  • xen-libs-32bit >= 4.9.1_08-3.26.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-302
SUSE Linux Enterprise Desktop 12 SP4
  • xen >= 4.11.0_08-1.11
  • xen-libs >= 4.11.0_08-1.11
  • xen-libs-32bit >= 4.11.0_08-1.11
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA xen
SUSE Linux Enterprise Point of Sale 11 SP3
  • xen >= 4.2.5_21-45.19.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.106.14-45.19.1
  • xen-kmp-pae >= 4.2.5_21_3.0.101_0.47.106.14-45.19.1
  • xen-libs >= 4.2.5_21-45.19.1
  • xen-tools-domU >= 4.2.5_21-45.19.1
Patchnames:
sleposp3-xen-13511
SUSE Linux Enterprise Server 11 SP3-LTSS
  • xen >= 4.2.5_21-45.19.1
  • xen-doc-html >= 4.2.5_21-45.19.1
  • xen-doc-pdf >= 4.2.5_21-45.19.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.106.14-45.19.1
  • xen-kmp-pae >= 4.2.5_21_3.0.101_0.47.106.14-45.19.1
  • xen-libs >= 4.2.5_21-45.19.1
  • xen-libs-32bit >= 4.2.5_21-45.19.1
  • xen-tools >= 4.2.5_21-45.19.1
  • xen-tools-domU >= 4.2.5_21-45.19.1
Patchnames:
slessp3-xen-13511
SUSE Linux Enterprise Server 11 SP4
  • xen >= 4.4.4_28-61.23.2
  • xen-doc-html >= 4.4.4_28-61.23.2
  • xen-kmp-default >= 4.4.4_28_3.0.101_108.35-61.23.2
  • xen-kmp-pae >= 4.4.4_28_3.0.101_108.35-61.23.2
  • xen-libs >= 4.4.4_28-61.23.2
  • xen-libs-32bit >= 4.4.4_28-61.23.2
  • xen-tools >= 4.4.4_28-61.23.2
  • xen-tools-domU >= 4.4.4_28-61.23.2
Patchnames:
slessp4-xen-13501
SUSE Linux Enterprise Server 12 SP1-LTSS
  • xen >= 4.5.5_24-22.43.1
  • xen-doc-html >= 4.5.5_24-22.43.1
  • xen-kmp-default >= 4.5.5_24_k3.12.74_60.64.82-22.43.1
  • xen-libs >= 4.5.5_24-22.43.1
  • xen-libs-32bit >= 4.5.5_24-22.43.1
  • xen-tools >= 4.5.5_24-22.43.1
  • xen-tools-domU >= 4.5.5_24-22.43.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-415
SUSE Linux Enterprise Server 12 SP2
  • xen >= 4.7.4_06-43.24.1
  • xen-doc-html >= 4.7.4_06-43.24.1
  • xen-libs >= 4.7.4_06-43.24.1
  • xen-libs-32bit >= 4.7.4_06-43.24.1
  • xen-tools >= 4.7.4_06-43.24.1
  • xen-tools-domU >= 4.7.4_06-43.24.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-325
SUSE Linux Enterprise Server 12 SP3
  • xen >= 4.9.1_08-3.26.1
  • xen-doc-html >= 4.9.1_08-3.26.1
  • xen-libs >= 4.9.1_08-3.26.1
  • xen-libs-32bit >= 4.9.1_08-3.26.1
  • xen-tools >= 4.9.1_08-3.26.1
  • xen-tools-domU >= 4.9.1_08-3.26.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-302
SUSE Linux Enterprise Server 12 SP4
  • xen >= 4.11.0_08-1.11
  • xen-doc-html >= 4.11.0_08-1.11
  • xen-libs >= 4.11.0_08-1.11
  • xen-libs-32bit >= 4.11.0_08-1.11
  • xen-tools >= 4.11.0_08-1.11
  • xen-tools-domU >= 4.11.0_08-1.11
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA xen
SUSE Linux Enterprise Server 12-LTSS
  • xen >= 4.4.4_28-22.62.1
  • xen-doc-html >= 4.4.4_28-22.62.1
  • xen-kmp-default >= 4.4.4_28_k3.12.61_52.119-22.62.1
  • xen-libs >= 4.4.4_28-22.62.1
  • xen-libs-32bit >= 4.4.4_28-22.62.1
  • xen-tools >= 4.4.4_28-22.62.1
  • xen-tools-domU >= 4.4.4_28-22.62.1
Patchnames:
SUSE-SLE-SERVER-12-2018-408
SUSE Linux Enterprise Server for SAP Applications 11 SP3-LTSS
  • xen >= 4.2.5_21-45.19.1
  • xen-doc-html >= 4.2.5_21-45.19.1
  • xen-doc-pdf >= 4.2.5_21-45.19.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.106.14-45.19.1
  • xen-kmp-pae >= 4.2.5_21_3.0.101_0.47.106.14-45.19.1
  • xen-libs >= 4.2.5_21-45.19.1
  • xen-libs-32bit >= 4.2.5_21-45.19.1
  • xen-tools >= 4.2.5_21-45.19.1
  • xen-tools-domU >= 4.2.5_21-45.19.1
Patchnames:
slessp3-xen-13511
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • xen >= 4.4.4_28-61.23.2
  • xen-doc-html >= 4.4.4_28-61.23.2
  • xen-kmp-default >= 4.4.4_28_3.0.101_108.35-61.23.2
  • xen-kmp-pae >= 4.4.4_28_3.0.101_108.35-61.23.2
  • xen-libs >= 4.4.4_28-61.23.2
  • xen-libs-32bit >= 4.4.4_28-61.23.2
  • xen-tools >= 4.4.4_28-61.23.2
  • xen-tools-domU >= 4.4.4_28-61.23.2
Patchnames:
slessp4-xen-13501
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • xen >= 4.5.5_24-22.43.1
  • xen-doc-html >= 4.5.5_24-22.43.1
  • xen-kmp-default >= 4.5.5_24_k3.12.74_60.64.82-22.43.1
  • xen-libs >= 4.5.5_24-22.43.1
  • xen-libs-32bit >= 4.5.5_24-22.43.1
  • xen-tools >= 4.5.5_24-22.43.1
  • xen-tools-domU >= 4.5.5_24-22.43.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2018-415
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • xen >= 4.5.5_24-22.43.1
  • xen-doc-html >= 4.5.5_24-22.43.1
  • xen-kmp-default >= 4.5.5_24_k3.12.74_60.64.82-22.43.1
  • xen-libs >= 4.5.5_24-22.43.1
  • xen-libs-32bit >= 4.5.5_24-22.43.1
  • xen-tools >= 4.5.5_24-22.43.1
  • xen-tools-domU >= 4.5.5_24-22.43.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-415
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • xen >= 4.7.4_06-43.24.1
  • xen-doc-html >= 4.7.4_06-43.24.1
  • xen-libs >= 4.7.4_06-43.24.1
  • xen-libs-32bit >= 4.7.4_06-43.24.1
  • xen-tools >= 4.7.4_06-43.24.1
  • xen-tools-domU >= 4.7.4_06-43.24.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-325
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • xen >= 4.9.1_08-3.26.1
  • xen-doc-html >= 4.9.1_08-3.26.1
  • xen-libs >= 4.9.1_08-3.26.1
  • xen-libs-32bit >= 4.9.1_08-3.26.1
  • xen-tools >= 4.9.1_08-3.26.1
  • xen-tools-domU >= 4.9.1_08-3.26.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-302
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • xen >= 4.4.4_28-22.62.1
  • xen-doc-html >= 4.4.4_28-22.62.1
  • xen-kmp-default >= 4.4.4_28_k3.12.61_52.119-22.62.1
  • xen-libs >= 4.4.4_28-22.62.1
  • xen-libs-32bit >= 4.4.4_28-22.62.1
  • xen-tools >= 4.4.4_28-22.62.1
  • xen-tools-domU >= 4.4.4_28-22.62.1
Patchnames:
SUSE-SLE-SERVER-12-2018-408
SUSE Linux Enterprise Software Development Kit 11 SP4
  • xen >= 4.4.4_28-61.23.2
  • xen-devel >= 4.4.4_28-61.23.2
Patchnames:
sdksp4-xen-13501
SUSE Linux Enterprise Software Development Kit 12 SP2
  • xen >= 4.7.4_06-43.24.1
  • xen-devel >= 4.7.4_06-43.24.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-325
SUSE Linux Enterprise Software Development Kit 12 SP3
  • xen >= 4.9.1_08-3.26.1
  • xen-devel >= 4.9.1_08-3.26.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-302
SUSE Linux Enterprise Software Development Kit 12 SP4
  • xen-devel >= 4.11.0_08-1.11
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA xen-devel
SUSE OpenStack Cloud 6
  • xen >= 4.5.5_24-22.43.1
  • xen-doc-html >= 4.5.5_24-22.43.1
  • xen-kmp-default >= 4.5.5_24_k3.12.74_60.64.82-22.43.1
  • xen-libs >= 4.5.5_24-22.43.1
  • xen-libs-32bit >= 4.5.5_24-22.43.1
  • xen-tools >= 4.5.5_24-22.43.1
  • xen-tools-domU >= 4.5.5_24-22.43.1
Patchnames:
SUSE-OpenStack-Cloud-6-2018-415
openSUSE Leap 42.3
  • xen >= 4.9.1_08-16.1
  • xen-debugsource >= 4.9.1_08-16.1
  • xen-devel >= 4.9.1_08-16.1
  • xen-doc-html >= 4.9.1_08-16.1
  • xen-libs >= 4.9.1_08-16.1
  • xen-libs-debuginfo >= 4.9.1_08-16.1
  • xen-tools >= 4.9.1_08-16.1
  • xen-tools-debuginfo >= 4.9.1_08-16.1
  • xen-tools-domU >= 4.9.1_08-16.1
  • xen-tools-domU-debuginfo >= 4.9.1_08-16.1
Patchnames:
openSUSE-2018-169


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 xen Released
CaaS Platform 2.0 xen Released
SUSE Linux Enterprise Desktop 12 SP2 xen Released
SUSE Linux Enterprise Desktop 12 SP3 xen Released
SUSE Linux Enterprise SDK 11 SP4 xen Released
SUSE Linux Enterprise SDK 12 SP2 xen Released
SUSE Linux Enterprise SDK 12 SP3 xen Released
SUSE Linux Enterprise Server 11 SP3 LTSS xen Released
SUSE Linux Enterprise Server 11 SP4 xen Released
SUSE Linux Enterprise Server 12 GA LTSS xen Released
SUSE Linux Enterprise Server 12 SP1 LTSS xen Released
SUSE Linux Enterprise Server 12 SP2 xen Released
SUSE Linux Enterprise Server 12 SP3 xen Released