CVE-2017-17669
CVE-2017-17669, security advisory, novell, suse linux, suse, security, cve

CVE-2017-17669

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2017-17669 at MITRE

Description

There is a heap-based buffer over-read in the Exiv2::Internal::PngChunk::keyTXTChunk function of pngchunk_int.cpp in Exiv2 0.26. A crafted PNG file will lead to a remote denial of service attack.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 2.1
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:L/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network Local
Access Complexity Medium Low
Authentication None None
Confidentiality Impact None Partial
Integrity Impact None None
Availability Impact Partial None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 4
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Access Vector Local Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact None Low
Integrity Impact None None
Availability Impact High None
SUSE Bugzilla entry: 1072928 [RESOLVED / WONTFIX]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • exiv2 >= 0.23-12.5.1
  • libexiv2-12 >= 0.23-12.5.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-2772
SUSE Linux Enterprise Desktop 12 SP4
  • exiv2 >= 0.23-12.5.1
  • libexiv2-12 >= 0.23-12.5.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2018-2772
SUSE Linux Enterprise Server 12 SP3
  • exiv2 >= 0.23-12.5.1
  • libexiv2-12 >= 0.23-12.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2772
SUSE Linux Enterprise Server 12 SP4
  • exiv2 >= 0.23-12.5.1
  • libexiv2-12 >= 0.23-12.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2018-2772
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • exiv2 >= 0.23-12.5.1
  • libexiv2-12 >= 0.23-12.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2772
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • exiv2 >= 0.23-12.5.1
  • libexiv2-12 >= 0.23-12.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2018-2772
SUSE Linux Enterprise Software Development Kit 12 SP3
  • exiv2 >= 0.23-12.5.1
  • libexiv2-devel >= 0.23-12.5.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-2772
SUSE Linux Enterprise Software Development Kit 12 SP4
  • exiv2 >= 0.23-12.5.1
  • libexiv2-devel >= 0.23-12.5.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2018-2772


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 exiv2 Affected
SUSE Linux Enterprise Desktop 12 SP3 exiv2 Released
SUSE Linux Enterprise Desktop 12 SP4 exiv2 Released
SUSE Linux Enterprise High Performance Computing 12 exiv2 Released
SUSE Linux Enterprise SDK 11 SP4 exiv2 Not affected
SUSE Linux Enterprise SDK 12 SP2 exiv2 Ignore
SUSE Linux Enterprise SDK 12 SP3 exiv2 Released
SUSE Linux Enterprise SDK 12 SP4 exiv2 Released
SUSE Linux Enterprise Server 11 SP3 LTSS exiv2 Not affected
SUSE Linux Enterprise Server 11 SP4 exiv2 Not affected
SUSE Linux Enterprise Server 12 GA LTSS exiv2 Ignore
SUSE Linux Enterprise Server 12 SP1 LTSS exiv2 Ignore
SUSE Linux Enterprise Server 12 SP2 exiv2 Ignore
SUSE Linux Enterprise Server 12 SP3 exiv2 Released
SUSE Linux Enterprise Server 12 SP4 exiv2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 exiv2 Released