CVE-2018-10887
CVE-2018-10887, security advisory, novell, suse linux, suse, security, cve

CVE-2018-10887

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2018-10887 at MITRE

Description

A flaw was found in libgit2 before version 0.27.3. It has been discovered that an unexpected sign extension in git_delta_apply function in delta.c file may lead to an integer overflow which in turn leads to an out of bound read, allowing to read before the base object. An attacker may use this flaw to leak memory addresses or cause a Denial of Service.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.1 6.5
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact None None
Availability Impact High Low
SUSE Bugzilla entry: 1100613 [CONFIRMED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Development Tools 15
  • libgit2 >= 0.26.6-3.5.2
  • libgit2-26 >= 0.26.6-3.5.2
  • libgit2-devel >= 0.26.6-3.5.2
Patchnames:
SUSE-SLE-Module-Development-Tools-15-2018-1731
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • libgit2-26 >= 0.26.8-3.8.1
  • libgit2-devel >= 0.26.8-3.8.1
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 SP1 GA libgit2-26
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libgit2 >= 0.24.1-7.6.1
  • libgit2-24 >= 0.24.1-7.6.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-2459
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libgit2-24 >= 0.24.1-7.6.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libgit2-24
SUSE Manager Server 3.1
  • libgit2 >= 0.24.1-7.6.1
  • libgit2-24 >= 0.24.1-7.6.1
Patchnames:
SUSE-SUSE-Manager-Server-3.1-2018-2459
SUSE Manager Server 3.2
  • libgit2 >= 0.24.1-7.6.1
  • libgit2-24 >= 0.24.1-7.6.1
Patchnames:
SUSE-SUSE-Manager-Server-3.2-2018-2459
openSUSE Leap 15.0
  • libgit2 >= 0.26.6-lp150.2.3.1
  • libgit2-26 >= 0.26.6-lp150.2.3.1
  • libgit2-26-32bit >= 0.26.6-lp150.2.3.1
  • libgit2-26-32bit-debuginfo >= 0.26.6-lp150.2.3.1
  • libgit2-26-debuginfo >= 0.26.6-lp150.2.3.1
  • libgit2-debugsource >= 0.26.6-lp150.2.3.1
  • libgit2-devel >= 0.26.6-lp150.2.3.1
Patchnames:
openSUSE-2019-638
openSUSE Leap 42.3
  • libgit2 >= 0.24.1-10.3.1
  • libgit2-24 >= 0.24.1-10.3.1
  • libgit2-24-32bit >= 0.24.1-10.3.1
  • libgit2-24-debuginfo >= 0.24.1-10.3.1
  • libgit2-24-debuginfo-32bit >= 0.24.1-10.3.1
  • libgit2-debugsource >= 0.24.1-10.3.1
  • libgit2-devel >= 0.24.1-10.3.1
Patchnames:
openSUSE-2018-1314


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Development Tools 15 GA libgit2 Released
SUSE Linux Enterprise SDK 12 SP3 libgit2 Released
SUSE Manager Server 3.1 libgit2 Released
SUSE Manager Server 3.2 libgit2 Released