CVE-2018-16841
CVE-2018-16841, security advisory, novell, suse linux, suse, security, cve

CVE-2018-16841

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2018-16841 at MITRE

Description

Samba from version 4.3.0 and before versions 4.7.12, 4.8.7 and 4.9.3 are vulnerable to a denial of service. When configured to accept smart-card authentication, Samba's KDC will call talloc_free() twice on the same memory if the principal in a validly signed certificate does not match the principal in the AS-REQ. This is only possible after authentication with a trusted certificate. talloc is robust against further corruption from a double-free with talloc_free() and directly calls abort(), terminating the KDC process.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 6.5
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
SUSE Bugzilla entry: 1116320 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Availability 15
  • ctdb >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • samba >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
Patchnames:
SUSE-SLE-Product-HA-15-2018-2888
SUSE Linux Enterprise High Availability 15 SP1
  • ctdb >= 4.9.5+git.149.9593f64a5c3-1.12
Patchnames:
SUSE Linux Enterprise High Availability 15 SP1 GA ctdb
SUSE Linux Enterprise Module for Basesystem 15
  • libdcerpc-binding0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libdcerpc-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libdcerpc-samr-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libdcerpc-samr0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libdcerpc0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libndr-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libndr-krb5pac-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libndr-krb5pac0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libndr-nbt-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libndr-nbt0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libndr-standard-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libndr-standard0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libndr0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libnetapi-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libnetapi0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsamba-credentials-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsamba-credentials0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsamba-errors-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsamba-errors0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsamba-hostconfig-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsamba-hostconfig0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsamba-passdb-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsamba-passdb0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsamba-policy-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsamba-policy0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsamba-util-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsamba-util0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsamdb-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsamdb0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsmbclient-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsmbclient0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsmbconf-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsmbconf0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsmbldap-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libsmbldap2 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libtevent-util-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libtevent-util0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libwbclient-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • libwbclient0 >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • samba >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • samba-client >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • samba-core-devel >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • samba-libs >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • samba-winbind >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2888
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libdcerpc-binding0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libdcerpc-binding0-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • libdcerpc-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libdcerpc-samr-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libdcerpc-samr0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libdcerpc0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libdcerpc0-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • libndr-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libndr-krb5pac-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libndr-krb5pac0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libndr-krb5pac0-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • libndr-nbt-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libndr-nbt0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libndr-nbt0-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • libndr-standard-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libndr-standard0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libndr-standard0-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • libndr0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libndr0-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • libnetapi-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libnetapi0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libnetapi0-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-credentials-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-credentials0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-credentials0-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-errors-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-errors0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-errors0-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-hostconfig-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-hostconfig0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-hostconfig0-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-passdb-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-passdb0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-passdb0-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-policy-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-policy-python3-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-policy0-python3 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-util-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-util0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamba-util0-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamdb-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamdb0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsamdb0-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsmbclient-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsmbclient0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsmbconf-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsmbconf0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsmbconf0-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsmbldap-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsmbldap2 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libsmbldap2-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • libtevent-util-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libtevent-util0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libtevent-util0-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • libwbclient-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • libwbclient0 >= 4.9.5+git.149.9593f64a5c3-1.12
  • libwbclient0-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • samba >= 4.9.5+git.149.9593f64a5c3-1.12
  • samba-client >= 4.9.5+git.149.9593f64a5c3-1.12
  • samba-core-devel >= 4.9.5+git.149.9593f64a5c3-1.12
  • samba-libs >= 4.9.5+git.149.9593f64a5c3-1.12
  • samba-libs-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
  • samba-libs-python3 >= 4.9.5+git.149.9593f64a5c3-1.12
  • samba-python3 >= 4.9.5+git.149.9593f64a5c3-1.12
  • samba-winbind >= 4.9.5+git.149.9593f64a5c3-1.12
  • samba-winbind-32bit >= 4.9.5+git.149.9593f64a5c3-1.12
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libdcerpc-binding0-32bit
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • ctdb-pcp-pmda >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • ctdb-tests >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • samba >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • samba-doc >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • samba-python >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • samba-test >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2018-2888
SUSE Linux Enterprise Module for additional PackageHub packages 15
  • samba >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • samba-python >= 4.7.11+git.140.6bd0e5b30d8-4.21.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-2018-2888


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 samba Not affected
SUSE Linux Enterprise Desktop 12 SP4 samba Not affected
SUSE Linux Enterprise High Availability 12 GA samba Not affected
SUSE Linux Enterprise High Availability 12 SP1 samba Not affected
SUSE Linux Enterprise High Availability 12 SP3 samba Not affected
SUSE Linux Enterprise High Availability 12 SP4 samba Not affected
SUSE Linux Enterprise High Availability 15 GA samba Released
SUSE Linux Enterprise High Performance Computing 12 samba Not affected
SUSE Linux Enterprise Module for Basesystem 15 GA samba Released
SUSE Linux Enterprise SDK 11 SP4 samba Not affected
SUSE Linux Enterprise SDK 12 SP3 samba Not affected
SUSE Linux Enterprise SDK 12 SP4 samba Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS samba Not affected
SUSE Linux Enterprise Server 11 SP4 samba Not affected
SUSE Linux Enterprise Server 12 GA LTSS samba Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS samba Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS samba Not affected
SUSE Linux Enterprise Server 12 SP3 samba Not affected
SUSE Linux Enterprise Server 12 SP4 samba Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 samba Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA samba Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 samba Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 samba Not affected
SUSE Storage 5 samba Not affected