CVE-2018-20843
CVE-2018-20843, security advisory, novell, suse linux, suse, security, cve

CVE-2018-20843

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2018-20843 at MITRE

Description

In libexpat in Expat before 2.2.7, XML input including XML names that contain a large number of colons could make the XML parser consume a high amount of RAM and CPU resources while processing (enough to be usable for denial-of-service attacks).

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 5.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact Low
SUSE Bugzilla entry: 1139937 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 3.0
  • expat >= 2.1.0-21.6.1
  • libexpat1 >= 2.1.0-21.6.1
Patchnames:
SUSE-CAASP-3.0-2019-1834
SUSE Linux Enterprise Desktop 12 SP4
  • expat >= 2.1.0-21.6.1
  • libexpat1 >= 2.1.0-21.6.1
  • libexpat1-32bit >= 2.1.0-21.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-1834
SUSE Linux Enterprise Module for Basesystem 15
  • expat >= 2.2.5-3.3.1
  • libexpat-devel >= 2.2.5-3.3.1
  • libexpat1 >= 2.2.5-3.3.1
  • libexpat1-32bit >= 2.2.5-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-1835
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • expat >= 2.2.5-3.3.1
  • libexpat-devel >= 2.2.5-3.3.1
  • libexpat1 >= 2.2.5-3.3.1
  • libexpat1-32bit >= 2.2.5-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-1835
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • expat >= 2.2.5-3.3.1
  • libexpat-devel-32bit >= 2.2.5-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-1835
SUSE Linux Enterprise Server 12 SP4
  • expat >= 2.1.0-21.6.1
  • libexpat1 >= 2.1.0-21.6.1
  • libexpat1-32bit >= 2.1.0-21.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1834
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • expat >= 2.1.0-21.6.1
  • libexpat1 >= 2.1.0-21.6.1
  • libexpat1-32bit >= 2.1.0-21.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1834
SUSE Linux Enterprise Software Development Kit 12 SP4
  • expat >= 2.1.0-21.6.1
  • libexpat-devel >= 2.1.0-21.6.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1834
openSUSE Leap 15.0
  • expat >= 2.2.5-lp150.2.3.1
  • expat-32bit-debuginfo >= 2.2.5-lp150.2.3.1
  • expat-debuginfo >= 2.2.5-lp150.2.3.1
  • expat-debugsource >= 2.2.5-lp150.2.3.1
  • libexpat-devel >= 2.2.5-lp150.2.3.1
  • libexpat-devel-32bit >= 2.2.5-lp150.2.3.1
  • libexpat1 >= 2.2.5-lp150.2.3.1
  • libexpat1-32bit >= 2.2.5-lp150.2.3.1
  • libexpat1-32bit-debuginfo >= 2.2.5-lp150.2.3.1
  • libexpat1-debuginfo >= 2.2.5-lp150.2.3.1
Patchnames:
openSUSE-2019-1777
openSUSE Leap 15.1
  • expat >= 2.2.5-lp151.3.3.1
  • expat-32bit-debuginfo >= 2.2.5-lp151.3.3.1
  • expat-debuginfo >= 2.2.5-lp151.3.3.1
  • expat-debugsource >= 2.2.5-lp151.3.3.1
  • libexpat-devel >= 2.2.5-lp151.3.3.1
  • libexpat-devel-32bit >= 2.2.5-lp151.3.3.1
  • libexpat1 >= 2.2.5-lp151.3.3.1
  • libexpat1-32bit >= 2.2.5-lp151.3.3.1
  • libexpat1-32bit-debuginfo >= 2.2.5-lp151.3.3.1
  • libexpat1-debuginfo >= 2.2.5-lp151.3.3.1
Patchnames:
openSUSE-2019-1777


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 expat Affected
CaaS Platform 2.0 expat Affected
CaaS Platform 3.0 expat Released
OpenStack Cloud Magnum Orchestration 7.0 expat In progress
SUSE Linux Enterprise Desktop 12 SP3 expat In progress
SUSE Linux Enterprise Desktop 12 SP4 expat Released
SUSE Linux Enterprise High Performance Computing 12 expat Released
SUSE Linux Enterprise Module for Basesystem 15 GA expat Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 expat Released
SUSE Linux Enterprise SDK 12 SP3 expat In progress
SUSE Linux Enterprise SDK 12 SP4 expat Released
SUSE Linux Enterprise Server 11 SP3 LTSS expat Affected
SUSE Linux Enterprise Server 11 SP4 LTSS expat Affected
SUSE Linux Enterprise Server 12 GA LTSS expat Affected
SUSE Linux Enterprise Server 12 SP1 LTSS expat Affected
SUSE Linux Enterprise Server 12 SP2 LTSS expat Affected
SUSE Linux Enterprise Server 12 SP3 expat In progress
SUSE Linux Enterprise Server 12 SP4 expat Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 expat Affected
SUSE Linux Enterprise Server for SAP Applications 12 GA expat Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 expat Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 expat Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 expat Released