CVE-2019-3839
CVE-2019-3839, security advisory, novell, suse linux, suse, security, cve

CVE-2019-3839

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2019-3839 at MITRE

Description

It was found that in ghostscript some privileged operators remained accessible from various places after the CVE-2019-6116 fix. A specially crafted PostScript file could use this flaw in order to, for example, have access to the file system outside of the constrains imposed by -dSAFER. Ghostscript versions before 9.27 are vulnerable.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 7.3
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Access Vector Local Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
SUSE Bugzilla entry: 1134156 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
HPE-Helion-OpenStack-8-2019-2478
SUSE Enterprise Storage 4
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-Storage-4-2019-2478
SUSE Enterprise Storage 5
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-Storage-5-2019-2478
SUSE Linux Enterprise Build System Kit 12 SP4
  • ghostscript-mini >= 9.27-23.28.1
  • ghostscript-mini-devel >= 9.27-23.28.1
Patchnames:
SUSE-SLE-BSK-12-SP4-2019-2478
SUSE Linux Enterprise Desktop 12 SP4
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-2478
SUSE Linux Enterprise Desktop 12 SP5
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP5-2019-2478
SUSE Linux Enterprise Module for Basesystem 15
  • ghostscript >= 9.27-3.21.1
  • ghostscript-devel >= 9.27-3.21.1
  • ghostscript-x11 >= 9.27-3.21.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-2460
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • ghostscript >= 9.27-3.21.1
  • ghostscript-devel >= 9.27-3.21.1
  • ghostscript-x11 >= 9.27-3.21.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-2460
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • ghostscript-mini >= 9.27-3.21.1
  • ghostscript-mini-devel >= 9.27-3.21.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-2460
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • ghostscript-mini >= 9.27-3.21.1
  • ghostscript-mini-devel >= 9.27-3.21.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2460
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-2478
SUSE Linux Enterprise Server 12 SP1-LTSS
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-2478
SUSE Linux Enterprise Server 12 SP2-BCL
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2478
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2478
SUSE Linux Enterprise Server 12 SP2-LTSS
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2478
SUSE Linux Enterprise Server 12 SP3-BCL
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2478
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2478
SUSE Linux Enterprise Server 12 SP3-LTSS
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-2478
SUSE Linux Enterprise Server 12 SP4
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2478
SUSE Linux Enterprise Server 12 SP5
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2019-2478
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-2478
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-2478
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-2478
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-2478
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-2478
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-2478
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2019-2478
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-2478
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-2478
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-2478
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-2478
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2019-2478
SUSE Linux Enterprise Software Development Kit 12 SP4
  • ghostscript >= 9.27-23.28.1
  • ghostscript-devel >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-2478
SUSE Linux Enterprise Software Development Kit 12 SP5
  • ghostscript >= 9.27-23.28.1
  • ghostscript-devel >= 9.27-23.28.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2019-2478
SUSE OpenStack Cloud 7
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-2478
SUSE OpenStack Cloud 8
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-OpenStack-Cloud-8-2019-2478
SUSE OpenStack Cloud Crowbar 8
  • ghostscript >= 9.27-23.28.1
  • ghostscript-x11 >= 9.27-23.28.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-2478
openSUSE Leap 15.0
  • ghostscript >= 9.27-lp150.2.23.1
  • ghostscript-debuginfo >= 9.27-lp150.2.23.1
  • ghostscript-debugsource >= 9.27-lp150.2.23.1
  • ghostscript-devel >= 9.27-lp150.2.23.1
  • ghostscript-mini >= 9.27-lp150.2.23.1
  • ghostscript-mini-debuginfo >= 9.27-lp150.2.23.1
  • ghostscript-mini-debugsource >= 9.27-lp150.2.23.1
  • ghostscript-mini-devel >= 9.27-lp150.2.23.1
  • ghostscript-x11 >= 9.27-lp150.2.23.1
  • ghostscript-x11-debuginfo >= 9.27-lp150.2.23.1
Patchnames:
openSUSE-2019-2222
openSUSE Leap 15.1
  • ghostscript >= 9.27-lp151.3.6.1
  • ghostscript-debuginfo >= 9.27-lp151.3.6.1
  • ghostscript-debugsource >= 9.27-lp151.3.6.1
  • ghostscript-devel >= 9.27-lp151.3.6.1
  • ghostscript-mini >= 9.27-lp151.3.6.1
  • ghostscript-mini-debuginfo >= 9.27-lp151.3.6.1
  • ghostscript-mini-debugsource >= 9.27-lp151.3.6.1
  • ghostscript-mini-devel >= 9.27-lp151.3.6.1
  • ghostscript-x11 >= 9.27-lp151.3.6.1
  • ghostscript-x11-debuginfo >= 9.27-lp151.3.6.1
Patchnames:
openSUSE-2019-2223


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Business Critical Linux 12 SP2 ghostscript Released
SUSE Linux Enterprise Desktop 10 SP3 ghostscript-library Affected
SUSE Linux Enterprise Desktop 10 SP4 ghostscript-library Affected
SUSE Linux Enterprise Desktop 11 GA ghostscript-library Affected
SUSE Linux Enterprise Desktop 11 SP1 ghostscript-library Affected
SUSE Linux Enterprise Desktop 11 SP2 ghostscript-library Affected
SUSE Linux Enterprise Desktop 11 SP3 ghostscript-library Affected
SUSE Linux Enterprise Desktop 11 SP4 ghostscript-library Affected
SUSE Linux Enterprise Desktop 12 GA ghostscript Affected
SUSE Linux Enterprise Desktop 12 SP1 ghostscript Affected
SUSE Linux Enterprise Desktop 12 SP2 ghostscript Affected
SUSE Linux Enterprise Desktop 12 SP3 ghostscript Affected
SUSE Linux Enterprise Desktop 12 SP4 ghostscript Released
SUSE Linux Enterprise High Performance Computing 12 ghostscript Released
SUSE Linux Enterprise Module for Basesystem 15 GA ghostscript Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 ghostscript Released
SUSE Linux Enterprise SDK 11 GA ghostscript-library Affected
SUSE Linux Enterprise SDK 11 SP1 ghostscript-library Affected
SUSE Linux Enterprise SDK 11 SP2 ghostscript-library Affected
SUSE Linux Enterprise SDK 11 SP3 ghostscript-library Affected
SUSE Linux Enterprise SDK 11 SP4 ghostscript-library Affected
SUSE Linux Enterprise SDK 12 GA ghostscript Affected
SUSE Linux Enterprise SDK 12 SP1 ghostscript Affected
SUSE Linux Enterprise SDK 12 SP2 ghostscript Affected
SUSE Linux Enterprise SDK 12 SP3 ghostscript Affected
SUSE Linux Enterprise SDK 12 SP4 ghostscript Released
SUSE Linux Enterprise Server 10 SP3 ghostscript-library Affected
SUSE Linux Enterprise Server 10 SP4 ghostscript-library Affected
SUSE Linux Enterprise Server 10 SP4 LTSS ghostscript-library Affected
SUSE Linux Enterprise Server 11 GA ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP1 ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP1 LTSS ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP2 ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP2 LTSS ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP3 ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP3 LTSS ghostscript-library Affected
SUSE Linux Enterprise Server 11 SP4 ghostscript-library Affected
SUSE Linux Enterprise Server 12 GA ghostscript Affected
SUSE Linux Enterprise Server 12 GA LTSS ghostscript Affected
SUSE Linux Enterprise Server 12 SP1 ghostscript Affected
SUSE Linux Enterprise Server 12 SP1 LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP2 ghostscript Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI ghostscript Affected
SUSE Linux Enterprise Server 12 SP3 ghostscript Affected
SUSE Linux Enterprise Server 12 SP3 LTSS ghostscript Released
SUSE Linux Enterprise Server 12 SP4 ghostscript Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 ghostscript-library Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 ghostscript-library Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 ghostscript-library Affected
SUSE Linux Enterprise Server for SAP Applications 12 GA ghostscript Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ghostscript Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ghostscript Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 ghostscript-library Affected
SUSE Linux Enterprise Server for VMWare 11 SP2 ghostscript-library Affected
SUSE Linux Enterprise Server for VMWare 11 SP3 ghostscript-library Affected