CVE-2019-3859
CVE-2019-3859, security advisory, novell, suse linux, suse, security, cve

CVE-2019-3859

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2019-3859 at MITRE

Description

An out of bounds read flaw was discovered in libssh2 before 1.8.1 in the _libssh2_packet_require and _libssh2_packet_requirev functions. A remote attacker who compromises a SSH server may be able to cause a Denial of Service or read data in the client memory.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:P/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.1 3.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None Low
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact None None
Availability Impact High Low
SUSE Bugzilla entries: 1128480 [RESOLVED / FIXED], 1130103 [RESOLVED / DUPLICATE], 1135434 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2019-1060
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2019-655
SUSE CaaS Platform 3.0
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-CAASP-3.0-2019-1060
SUSE-CAASP-3.0-2019-655
SUSE CaaS Platform ALL
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-CAASP-ALL-2019-1060
SUSE-CAASP-ALL-2019-655
SUSE Enterprise Storage 4
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-Storage-4-2019-1060
SUSE-Storage-4-2019-655
SUSE Linux Enterprise Desktop 12 SP3
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2019-1060
SUSE-SLE-DESKTOP-12-SP3-2019-655
SUSE Linux Enterprise Desktop 12 SP4
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-1060
SUSE-SLE-DESKTOP-12-SP4-2019-655
SUSE Linux Enterprise Module for Basesystem 15
  • libssh2-1 >= 1.8.0-4.6.1
  • libssh2-devel >= 1.8.0-4.6.1
  • libssh2_org >= 1.8.0-4.6.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-1059
SUSE-SLE-Module-Basesystem-15-2019-637
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libssh2-1 >= 1.8.0-4.6.1
  • libssh2-devel >= 1.8.0-4.6.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libssh2-1
SUSE Linux Enterprise Point of Sale 11 SP3
  • libssh2-1 >= 1.2.9-4.2.12.8.1
  • libssh2_org >= 1.2.9-4.2.12.8.1
Patchnames:
sleposp3-libssh2_org-13997
sleposp3-libssh2_org-14032
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-1060
SUSE-SLE-POS-12-SP2-CLIENT-2019-655
SUSE Linux Enterprise Server 11 SP4
  • libssh2-1 >= 1.4.3-17.3.1
  • libssh2_org >= 1.4.3-17.3.1
Patchnames:
slessp4-libssh2_org-13982
SUSE Linux Enterprise Server 11 SP4-LTSS
  • libssh2-1 >= 1.4.3-17.6.1
  • libssh2_org >= 1.4.3-17.6.1
Patchnames:
slessp4-libssh2_org-14031
SUSE Linux Enterprise Server 12 SP1-LTSS
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-1060
SUSE-SLE-SERVER-12-SP1-2019-655
SUSE Linux Enterprise Server 12 SP2-BCL
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-1060
SUSE-SLE-SERVER-12-SP2-BCL-2019-655
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-1060
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-655
SUSE Linux Enterprise Server 12 SP2-LTSS
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-1060
SUSE-SLE-SERVER-12-SP2-2019-655
SUSE Linux Enterprise Server 12 SP3
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-1060
SUSE-SLE-SERVER-12-SP3-2019-655
SUSE Linux Enterprise Server 12 SP4
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1060
SUSE-SLE-SERVER-12-SP4-2019-655
SUSE Linux Enterprise Server 12-LTSS
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SERVER-12-2019-1060
SUSE-SLE-SERVER-12-2019-655
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libssh2-1 >= 1.4.3-17.3.1
  • libssh2_org >= 1.4.3-17.3.1
Patchnames:
slessp4-libssh2_org-13982
SUSE Linux Enterprise Server for SAP Applications 11 SP4-LTSS
  • libssh2-1 >= 1.4.3-17.6.1
  • libssh2_org >= 1.4.3-17.6.1
Patchnames:
slessp4-libssh2_org-14031
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-1060
SUSE-SLE-SAP-12-SP1-2019-655
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-1060
SUSE-SLE-SERVER-12-SP1-2019-655
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-1060
SUSE-SLE-SAP-12-SP2-2019-655
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-1060
SUSE-SLE-SERVER-12-SP2-BCL-2019-655
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-1060
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-655
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-1060
SUSE-SLE-SERVER-12-SP2-2019-655
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-1060
SUSE-SLE-SERVER-12-SP3-2019-655
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1060
SUSE-SLE-SERVER-12-SP4-2019-655
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SERVER-12-2019-1060
SUSE-SLE-SERVER-12-2019-655
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libssh2-1 >= 1.4.3-17.3.1
  • libssh2-1-32bit >= 1.4.3-17.3.1
  • libssh2-1-x86 >= 1.4.3-17.3.1
  • libssh2-devel >= 1.4.3-17.3.1
  • libssh2_org >= 1.4.3-17.3.1
Patchnames:
sdksp4-libssh2_org-13982
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libssh2-devel >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-1060
SUSE-SLE-SDK-12-SP3-2019-655
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libssh2-devel >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1060
SUSE-SLE-SDK-12-SP4-2019-655
SUSE OpenStack Cloud 7
  • libssh2-1 >= 1.4.3-20.6.1
  • libssh2-1-32bit >= 1.4.3-20.6.1
  • libssh2_org >= 1.4.3-20.6.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-1060
SUSE-OpenStack-Cloud-7-2019-655
openSUSE Leap 15.0
  • libssh2-1 >= 1.8.0-lp150.3.6.1
  • libssh2-1-32bit >= 1.8.0-lp150.3.6.1
  • libssh2-1-32bit-debuginfo >= 1.8.0-lp150.3.6.1
  • libssh2-1-debuginfo >= 1.8.0-lp150.3.6.1
  • libssh2-devel >= 1.8.0-lp150.3.6.1
  • libssh2_org >= 1.8.0-lp150.3.6.1
  • libssh2_org-debugsource >= 1.8.0-lp150.3.6.1
Patchnames:
openSUSE-2019-1109
openSUSE-2019-1291
openSUSE Leap 42.3
  • libssh2-1 >= 1.4.3-19.6.1
  • libssh2-1-32bit >= 1.4.3-19.6.1
  • libssh2-1-debuginfo >= 1.4.3-19.6.1
  • libssh2-1-debuginfo-32bit >= 1.4.3-19.6.1
  • libssh2-devel >= 1.4.3-19.6.1
  • libssh2_org >= 1.4.3-19.6.1
  • libssh2_org-debugsource >= 1.4.3-19.6.1
Patchnames:
openSUSE-2019-1075
openSUSE-2019-1290


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 libssh2_org Released
CaaS Platform 3.0 libssh2_org Released
OpenStack Cloud Magnum Orchestration 7.0 libssh2_org Released
SUSE Linux Enterprise Desktop 12 SP3 libssh Not affected
SUSE Linux Enterprise Desktop 12 SP3 libssh2_org Released
SUSE Linux Enterprise Desktop 12 SP4 libssh Not affected
SUSE Linux Enterprise Desktop 12 SP4 libssh2_org Released
SUSE Linux Enterprise High Performance Computing 12 libssh Not affected
SUSE Linux Enterprise High Performance Computing 12 libssh2_org Released
SUSE Linux Enterprise Module for Basesystem 15 GA libssh Not affected
SUSE Linux Enterprise Module for Basesystem 15 GA libssh2_org Released
SUSE Linux Enterprise SDK 11 SP4 libssh Not affected
SUSE Linux Enterprise SDK 11 SP4 libssh2_org Released
SUSE Linux Enterprise SDK 12 SP3 libssh Not affected
SUSE Linux Enterprise SDK 12 SP3 libssh2_org Released
SUSE Linux Enterprise SDK 12 SP4 libssh Not affected
SUSE Linux Enterprise SDK 12 SP4 libssh2_org Released
SUSE Linux Enterprise Server 11 SP3 LTSS libssh2_org Affected
SUSE Linux Enterprise Server 11 SP4 libssh2_org Released
SUSE Linux Enterprise Server 11 SP4 LTSS libssh2_org Released
SUSE Linux Enterprise Server 12 GA LTSS libssh2_org Released
SUSE Linux Enterprise Server 12 SP1 LTSS libssh2_org Released
SUSE Linux Enterprise Server 12 SP2 LTSS libssh2_org Released
SUSE Linux Enterprise Server 12 SP3 libssh2_org Released
SUSE Linux Enterprise Server 12 SP4 libssh Not affected
SUSE Linux Enterprise Server 12 SP4 libssh2_org Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 libssh2_org Affected
SUSE Linux Enterprise Server for SAP Applications 12 GA libssh2_org Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libssh2_org Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libssh Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libssh2_org Released
SUSE Linux Enterprise Workstation Extension 12 SP3 libssh Not affected