CVE-2019-3871
CVE-2019-3871, security advisory, novell, suse linux, suse, security, cve

CVE-2019-3871

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2019-3871 at MITRE

Description

A vulnerability was found in PowerDNS Authoritative Server before 4.0.7 and before 4.1.7. An insufficient validation of data coming from the user when building a HTTP request from a DNS query in the HTTP Connector of the Remote backend, allowing a remote user to cause a denial of service by making the server connect to an invalid endpoint, or possibly information disclosure by making the server connect to an internal endpoint and somehow extracting meaningful information about the response

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 7
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High High
CVSSv3 Version 3.0 3.0
SUSE Bugzilla entry: 1129734 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE OpenStack Cloud 9
  • ardana-ansible >= 9.0+git.1568821007.4e73730-3.13.3
  • ardana-horizon >= 9.0+git.1569869028.8edfc22-3.10.3
  • ardana-keystone >= 9.0+git.1570035317.78077ac-3.10.3
  • ardana-manila >= 9.0+git.1569444107.add6a40-3.9.3
  • ardana-neutron >= 9.0+git.1571328680.3a89cb8-3.13.3
  • grafana >= 6.2.5-3.9.3
  • openstack-cinder >= 13.0.8~dev8-3.13.5
  • openstack-cinder-api >= 13.0.8~dev8-3.13.5
  • openstack-cinder-backup >= 13.0.8~dev8-3.13.5
  • openstack-cinder-scheduler >= 13.0.8~dev8-3.13.5
  • openstack-cinder-volume >= 13.0.8~dev8-3.13.5
  • openstack-dashboard >= 14.0.5~dev1-3.9.4
  • openstack-horizon-plugin-manila-ui >= 2.16.2~dev2-3.3.3
  • openstack-keystone >= 14.1.1~dev26-3.13.4
  • openstack-manila >= 7.3.1~dev15-4.13.4
  • openstack-manila-api >= 7.3.1~dev15-4.13.4
  • openstack-manila-data >= 7.3.1~dev15-4.13.4
  • openstack-manila-scheduler >= 7.3.1~dev15-4.13.4
  • openstack-manila-share >= 7.3.1~dev15-4.13.4
  • openstack-neutron >= 13.0.6~dev3-3.13.4
  • openstack-neutron-dhcp-agent >= 13.0.6~dev3-3.13.4
  • openstack-neutron-fwaas >= 13.0.3~dev2-3.6.3
  • openstack-neutron-ha-tool >= 13.0.6~dev3-3.13.4
  • openstack-neutron-l3-agent >= 13.0.6~dev3-3.13.4
  • openstack-neutron-lbaas >= 13.0.1~dev15-3.10.3
  • openstack-neutron-lbaas-agent >= 13.0.1~dev15-3.10.3
  • openstack-neutron-linuxbridge-agent >= 13.0.6~dev3-3.13.4
  • openstack-neutron-macvtap-agent >= 13.0.6~dev3-3.13.4
  • openstack-neutron-metadata-agent >= 13.0.6~dev3-3.13.4
  • openstack-neutron-metering-agent >= 13.0.6~dev3-3.13.4
  • openstack-neutron-openvswitch-agent >= 13.0.6~dev3-3.13.4
  • openstack-neutron-server >= 13.0.6~dev3-3.13.4
  • openstack-nova >= 18.2.4~dev18-3.13.5
  • openstack-nova-api >= 18.2.4~dev18-3.13.5
  • openstack-nova-cells >= 18.2.4~dev18-3.13.5
  • openstack-nova-compute >= 18.2.4~dev18-3.13.5
  • openstack-nova-conductor >= 18.2.4~dev18-3.13.5
  • openstack-nova-console >= 18.2.4~dev18-3.13.5
  • openstack-nova-novncproxy >= 18.2.4~dev18-3.13.5
  • openstack-nova-placement-api >= 18.2.4~dev18-3.13.5
  • openstack-nova-scheduler >= 18.2.4~dev18-3.13.5
  • openstack-nova-serialproxy >= 18.2.4~dev18-3.13.5
  • openstack-nova-vncproxy >= 18.2.4~dev18-3.13.5
  • openstack-octavia >= 3.2.1~dev1-3.13.3
  • openstack-octavia-amphora-agent >= 3.2.1~dev1-3.13.3
  • openstack-octavia-amphora-image >= 0.1.1-7.3.4
  • openstack-octavia-amphora-image-x86_64 >= 0.1.1-7.3.4
  • openstack-octavia-api >= 3.2.1~dev1-3.13.3
  • openstack-octavia-health-manager >= 3.2.1~dev1-3.13.3
  • openstack-octavia-housekeeping >= 3.2.1~dev1-3.13.3
  • openstack-octavia-worker >= 3.2.1~dev1-3.13.3
  • pdns >= 4.1.8-3.3.3
  • pdns-backend-mysql >= 4.1.8-3.3.3
  • python-Django1 >= 1.11.24-3.12.3
  • python-cinder >= 13.0.8~dev8-3.13.5
  • python-horizon >= 14.0.5~dev1-3.9.4
  • python-horizon-plugin-manila-ui >= 2.16.2~dev2-3.3.3
  • python-keystone >= 14.1.1~dev26-3.13.4
  • python-keystonemiddleware >= 5.2.1-11.4
  • python-manila >= 7.3.1~dev15-4.13.4
  • python-neutron >= 13.0.6~dev3-3.13.4
  • python-neutron-fwaas >= 13.0.3~dev2-3.6.3
  • python-neutron-lbaas >= 13.0.1~dev15-3.10.3
  • python-nova >= 18.2.4~dev18-3.13.5
  • python-octavia >= 3.2.1~dev1-3.13.3
  • python-octaviaclient >= 1.6.1-3.3.3
  • python-openstack_auth >= 14.0.5~dev1-3.9.4
  • python-os-brick >= 2.5.8-3.6.3
  • python-os-brick-common >= 2.5.8-3.6.3
  • python-oslo.cache >= 1.30.4-3.3.3
  • python-oslo.messaging >= 8.1.4-3.3.3
  • venv-openstack-barbican >= 7.0.1~dev18-3.11.3
  • venv-openstack-barbican-x86_64 >= 7.0.1~dev18-3.11.3
  • venv-openstack-cinder >= 13.0.8~dev8-3.11.3
  • venv-openstack-cinder-x86_64 >= 13.0.8~dev8-3.11.3
  • venv-openstack-designate >= 7.0.1~dev22-3.11.3
  • venv-openstack-designate-x86_64 >= 7.0.1~dev22-3.11.3
  • venv-openstack-glance >= 17.0.1~dev30-3.11.3
  • venv-openstack-glance-x86_64 >= 17.0.1~dev30-3.11.3
  • venv-openstack-heat >= 11.0.3~dev23-3.11.3
  • venv-openstack-heat-x86_64 >= 11.0.3~dev23-3.11.3
  • venv-openstack-horizon >= 14.0.5~dev1-4.11.3
  • venv-openstack-horizon-x86_64 >= 14.0.5~dev1-4.11.3
  • venv-openstack-keystone >= 14.1.1~dev26-3.11.3
  • venv-openstack-keystone-x86_64 >= 14.1.1~dev26-3.11.3
  • venv-openstack-magnum >= 7.1.1~dev28-4.11.3
  • venv-openstack-magnum-x86_64 >= 7.1.1~dev28-4.11.3
  • venv-openstack-manila >= 7.3.1~dev15-3.11.3
  • venv-openstack-manila-x86_64 >= 7.3.1~dev15-3.11.3
  • venv-openstack-monasca >= 2.7.1~dev10-3.11.3
  • venv-openstack-monasca-ceilometer >= 1.8.2~dev3-3.11.3
  • venv-openstack-monasca-ceilometer-x86_64 >= 1.8.2~dev3-3.11.3
  • venv-openstack-monasca-x86_64 >= 2.7.1~dev10-3.11.3
  • venv-openstack-neutron >= 13.0.6~dev3-6.11.3
  • venv-openstack-neutron-x86_64 >= 13.0.6~dev3-6.11.3
  • venv-openstack-nova >= 18.2.4~dev18-3.11.3
  • venv-openstack-nova-x86_64 >= 18.2.4~dev18-3.11.3
  • venv-openstack-octavia >= 3.2.1~dev1-4.11.3
  • venv-openstack-octavia-x86_64 >= 3.2.1~dev1-4.11.3
  • venv-openstack-sahara >= 9.0.2~dev12-3.11.3
  • venv-openstack-sahara-x86_64 >= 9.0.2~dev12-3.11.3
  • venv-openstack-swift >= 2.19.2~dev1-2.8.3
  • venv-openstack-swift-x86_64 >= 2.19.2~dev1-2.8.3
Patchnames:
SUSE-OpenStack-Cloud-9-2019-2906
SUSE OpenStack Cloud Crowbar 9
  • crowbar-core >= 6.0+git.1571412352.8da4d261f-3.13.3
  • crowbar-core-branding-upstream >= 6.0+git.1571412352.8da4d261f-3.13.3
  • crowbar-openstack >= 6.0+git.1572264221.3826a58b8-3.13.3
  • grafana >= 6.2.5-3.9.3
  • openstack-cinder >= 13.0.8~dev8-3.13.5
  • openstack-cinder-api >= 13.0.8~dev8-3.13.5
  • openstack-cinder-backup >= 13.0.8~dev8-3.13.5
  • openstack-cinder-scheduler >= 13.0.8~dev8-3.13.5
  • openstack-cinder-volume >= 13.0.8~dev8-3.13.5
  • openstack-dashboard >= 14.0.5~dev1-3.9.4
  • openstack-horizon-plugin-manila-ui >= 2.16.2~dev2-3.3.3
  • openstack-keystone >= 14.1.1~dev26-3.13.4
  • openstack-manila >= 7.3.1~dev15-4.13.4
  • openstack-manila-api >= 7.3.1~dev15-4.13.4
  • openstack-manila-data >= 7.3.1~dev15-4.13.4
  • openstack-manila-scheduler >= 7.3.1~dev15-4.13.4
  • openstack-manila-share >= 7.3.1~dev15-4.13.4
  • openstack-neutron >= 13.0.6~dev3-3.13.4
  • openstack-neutron-dhcp-agent >= 13.0.6~dev3-3.13.4
  • openstack-neutron-fwaas >= 13.0.3~dev2-3.6.3
  • openstack-neutron-ha-tool >= 13.0.6~dev3-3.13.4
  • openstack-neutron-l3-agent >= 13.0.6~dev3-3.13.4
  • openstack-neutron-lbaas >= 13.0.1~dev15-3.10.3
  • openstack-neutron-lbaas-agent >= 13.0.1~dev15-3.10.3
  • openstack-neutron-linuxbridge-agent >= 13.0.6~dev3-3.13.4
  • openstack-neutron-macvtap-agent >= 13.0.6~dev3-3.13.4
  • openstack-neutron-metadata-agent >= 13.0.6~dev3-3.13.4
  • openstack-neutron-metering-agent >= 13.0.6~dev3-3.13.4
  • openstack-neutron-openvswitch-agent >= 13.0.6~dev3-3.13.4
  • openstack-neutron-server >= 13.0.6~dev3-3.13.4
  • openstack-nova >= 18.2.4~dev18-3.13.5
  • openstack-nova-api >= 18.2.4~dev18-3.13.5
  • openstack-nova-cells >= 18.2.4~dev18-3.13.5
  • openstack-nova-compute >= 18.2.4~dev18-3.13.5
  • openstack-nova-conductor >= 18.2.4~dev18-3.13.5
  • openstack-nova-console >= 18.2.4~dev18-3.13.5
  • openstack-nova-novncproxy >= 18.2.4~dev18-3.13.5
  • openstack-nova-placement-api >= 18.2.4~dev18-3.13.5
  • openstack-nova-scheduler >= 18.2.4~dev18-3.13.5
  • openstack-nova-serialproxy >= 18.2.4~dev18-3.13.5
  • openstack-nova-vncproxy >= 18.2.4~dev18-3.13.5
  • openstack-octavia >= 3.2.1~dev1-3.13.3
  • openstack-octavia-amphora-agent >= 3.2.1~dev1-3.13.3
  • openstack-octavia-amphora-image >= 0.1.1-7.3.4
  • openstack-octavia-amphora-image-x86_64 >= 0.1.1-7.3.4
  • openstack-octavia-api >= 3.2.1~dev1-3.13.3
  • openstack-octavia-health-manager >= 3.2.1~dev1-3.13.3
  • openstack-octavia-housekeeping >= 3.2.1~dev1-3.13.3
  • openstack-octavia-worker >= 3.2.1~dev1-3.13.3
  • python-Django1 >= 1.11.24-3.12.3
  • python-cinder >= 13.0.8~dev8-3.13.5
  • python-horizon >= 14.0.5~dev1-3.9.4
  • python-horizon-plugin-manila-ui >= 2.16.2~dev2-3.3.3
  • python-keystone >= 14.1.1~dev26-3.13.4
  • python-keystonemiddleware >= 5.2.1-11.4
  • python-manila >= 7.3.1~dev15-4.13.4
  • python-neutron >= 13.0.6~dev3-3.13.4
  • python-neutron-fwaas >= 13.0.3~dev2-3.6.3
  • python-neutron-lbaas >= 13.0.1~dev15-3.10.3
  • python-nova >= 18.2.4~dev18-3.13.5
  • python-octavia >= 3.2.1~dev1-3.13.3
  • python-octaviaclient >= 1.6.1-3.3.3
  • python-openstack_auth >= 14.0.5~dev1-3.9.4
  • python-os-brick >= 2.5.8-3.6.3
  • python-os-brick-common >= 2.5.8-3.6.3
  • python-oslo.cache >= 1.30.4-3.3.3
  • python-oslo.messaging >= 8.1.4-3.3.3
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2019-2906
SUSE Package Hub for SUSE Linux Enterprise 12 SP1
  • pdns >= 4.1.7-17.1
  • pdns-backend-geoip >= 4.1.2-lp150.3.10.1
  • pdns-backend-geoip-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-backend-godbc >= 4.1.7-17.1
  • pdns-backend-godbc-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-backend-ldap >= 4.1.7-17.1
  • pdns-backend-ldap-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-backend-lua >= 4.1.7-17.1
  • pdns-backend-lua-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-backend-mydns >= 4.1.7-17.1
  • pdns-backend-mydns-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-backend-mysql >= 4.1.7-17.1
  • pdns-backend-mysql-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-backend-postgresql >= 4.1.7-17.1
  • pdns-backend-postgresql-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-backend-remote >= 4.1.7-17.1
  • pdns-backend-remote-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-backend-sqlite3 >= 4.1.7-17.1
  • pdns-backend-sqlite3-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-debugsource >= 4.1.2-lp150.3.10.1
Patchnames:
openSUSE-2019-1128
openSUSE Leap 15.0
  • pdns >= 4.1.2-lp150.3.10.1
  • pdns-backend-geoip >= 4.1.2-lp150.3.10.1
  • pdns-backend-geoip-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-backend-godbc >= 4.1.2-lp150.3.10.1
  • pdns-backend-godbc-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-backend-ldap >= 4.1.2-lp150.3.10.1
  • pdns-backend-ldap-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-backend-lua >= 4.1.2-lp150.3.10.1
  • pdns-backend-lua-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-backend-mydns >= 4.1.2-lp150.3.10.1
  • pdns-backend-mydns-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-backend-mysql >= 4.1.2-lp150.3.10.1
  • pdns-backend-mysql-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-backend-postgresql >= 4.1.2-lp150.3.10.1
  • pdns-backend-postgresql-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-backend-remote >= 4.1.2-lp150.3.10.1
  • pdns-backend-remote-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-backend-sqlite3 >= 4.1.2-lp150.3.10.1
  • pdns-backend-sqlite3-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-debuginfo >= 4.1.2-lp150.3.10.1
  • pdns-debugsource >= 4.1.2-lp150.3.10.1
Patchnames:
openSUSE-2019-1128
openSUSE Leap 42.3
  • pdns >= 4.0.3-18.1
  • pdns-backend-geoip >= 4.0.3-18.1
  • pdns-backend-geoip-debuginfo >= 4.0.3-18.1
  • pdns-backend-godbc >= 4.0.3-18.1
  • pdns-backend-godbc-debuginfo >= 4.0.3-18.1
  • pdns-backend-ldap >= 4.0.3-18.1
  • pdns-backend-ldap-debuginfo >= 4.0.3-18.1
  • pdns-backend-lua >= 4.0.3-18.1
  • pdns-backend-lua-debuginfo >= 4.0.3-18.1
  • pdns-backend-mydns >= 4.0.3-18.1
  • pdns-backend-mydns-debuginfo >= 4.0.3-18.1
  • pdns-backend-mysql >= 4.0.3-18.1
  • pdns-backend-mysql-debuginfo >= 4.0.3-18.1
  • pdns-backend-postgresql >= 4.0.3-18.1
  • pdns-backend-postgresql-debuginfo >= 4.0.3-18.1
  • pdns-backend-remote >= 4.0.3-18.1
  • pdns-backend-remote-debuginfo >= 4.0.3-18.1
  • pdns-backend-sqlite3 >= 4.0.3-18.1
  • pdns-backend-sqlite3-debuginfo >= 4.0.3-18.1
  • pdns-debuginfo >= 4.0.3-18.1
  • pdns-debugsource >= 4.0.3-18.1
Patchnames:
openSUSE-2019-1128


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 pdns Affected
SUSE Openstack Cloud 8 pdns Affected
SUSE Openstack Cloud 9 pdns Released