CVE-2019-8308
CVE-2019-8308, security advisory, novell, suse linux, suse, security, cve

CVE-2019-8308

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2019-8308 at MITRE

Description

Flatpak before 1.0.7, and 1.1.x and 1.2.x before 1.2.3, exposes /proc in the apply_extra script sandbox, which allows attackers to modify a host-side executable file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 7.7
Vector AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
Access Vector Local
Access Complexity High
Privileges Required None
User Interaction Required
Scope Changed
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1125431 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15
  • flatpak >= 0.10.4-4.10.1
  • flatpak-devel >= 0.10.4-4.10.1
  • libflatpak0 >= 0.10.4-4.10.1
  • typelib-1_0-Flatpak-1_0 >= 0.10.4-4.10.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2019-2185
openSUSE Leap 15.0
  • flatpak >= 0.10.4-lp150.8.1
  • flatpak-debuginfo >= 0.10.4-lp150.8.1
  • flatpak-debugsource >= 0.10.4-lp150.8.1
  • flatpak-devel >= 0.10.4-lp150.8.1
  • libflatpak0 >= 0.10.4-lp150.8.1
  • libflatpak0-debuginfo >= 0.10.4-lp150.8.1
  • typelib-1_0-Flatpak-1_0 >= 0.10.4-lp150.8.1
Patchnames:
openSUSE-2019-2038


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Desktop Applications 15 GA flatpak Released